19 lines
375 B
Nix
19 lines
375 B
Nix
{ pkgs ? import <nixpkgs> { overlays = [ (import (builtins.fetchTarball https://github.com/mozilla/nixpkgs-mozilla/archive/master.tar.gz)) ]; },}:
|
|
with pkgs;
|
|
|
|
mkShell {
|
|
nativeBuildInputs = with xorg; [
|
|
pkg-config
|
|
] ++ [
|
|
cargo
|
|
rustc
|
|
];
|
|
buildInputs = [
|
|
latest.rustChannels.stable.rust
|
|
xorg.libX11
|
|
xorg.libXi
|
|
xorg.libXtst
|
|
libevdev
|
|
];
|
|
}
|